Kernel Update 5.4.51 breaks luma python library

A place to discuss any software issues you are having with your CrowPi
Post Reply
g7jjf
Posts: 13
Joined: Mon Apr 06, 2020 1:19 pm

Kernel Update 5.4.51 breaks luma python library

Post by g7jjf »

I have just tried to run a python program which uses the luma library to drive the dot matrix display.

I got an error similar to :

Code: Select all

Traceback (most recent call last):
  File "./matrix_demo.py", line 120, in <module>
    demo(args.cascaded, args.block_orientation, args.rotate)
  File "./matrix_demo.py", line 20, in demo
    serial = spi(port=0, device=0, gpio=noop())
  File "/usr/local/lib/python2.7/dist-packages/luma/core/interface/serial.py", line 281, in __init__
    self._spi.cshigh = cs_high
SystemError: error return without exception set
Turns out there is a problem with the spidev driver which was updated in 5.4.51 to fix a memory leak.

The advice was to revert the spidev driver back to a previous version with the following command :

Code: Select all

pip3 install spidev==3.4 --force-reinstall
I did this and now my python code is working again !

2600Sam
Posts: 21
Joined: Thu Jul 30, 2020 6:04 am

Re: Kernel Update 5.4.51 breaks luma python library

Post by 2600Sam »

I was thinking I should up date the software on my CrowPi, but now I don't know, thinking wait now!
why put it off today when you can out if off tomorrow!!

Post Reply